#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(:#).*"
Local $sString = "grep: ./lib/ignite-core-2.10.0.jar: binary file matches" & @CRLF & _
"./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender" & @CRLF & _
"./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB" & @CRLF & _
"./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0" & @CRLF & _
"./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2" & @CRLF & _
"./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender" & @CRLF & _
"./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")