const regex = /(:#).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:#).*', 'gm')
const str = `grep: ./lib/ignite-core-2.10.0.jar: binary file matches
./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender
./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB
./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0
./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2
./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender
./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}