import Foundation
let pattern = ##"(:#).*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
grep: ./lib/ignite-core-2.10.0.jar: binary file matches
./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender
./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB
./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0
./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2
./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender
./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)