using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(:#).*";
string input = @"grep: ./lib/ignite-core-2.10.0.jar: binary file matches
./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender
./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB
./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0
./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2
./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender
./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}