import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(:#).*";
final String string = "grep: ./lib/ignite-core-2.10.0.jar: binary file matches\n"
+ "./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender\n"
+ "./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB\n"
+ "./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0\n"
+ "./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2\n"
+ "./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender\n"
+ "./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}