import re
regex = re.compile(r"(:#).*", flags=re.MULTILINE)
test_str = ("grep: ./lib/ignite-core-2.10.0.jar: binary file matches\n"
"./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender\n"
"./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB\n"
"./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0\n"
"./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2\n"
"./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender\n"
"./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")