# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\babc(?![^<]*>)/xxx/g;t' <<< "abcdef abc<span abc>defabc abcdef</span> abc defabc"