$re = '/\babc(?![^<]*>)/';
$str = 'abcdef abc<span abc>defabc abcdef</span> abc defabc';
$subst = "xxx";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;