const regex = /\babc(?![^<]*>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\babc(?![^<]*>)', 'g')
const str = `abcdef abc<span abc>defabc abcdef</span> abc defabc`;
const subst = `xxx`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);