use strict;
my $str = 'abcdef abc<span abc>defabc abcdef</span> abc defabc';
my $regex = qr/\babc(?![^<]*>)/p;
my $subst = 'xxx';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";