#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\babc(?![^<]*>)"
Local $sString = "abcdef abc<span abc>defabc abcdef</span> abc defabc"
Local $sSubst = "xxx"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)