using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\babc(?![^<]*>)";
string substitution = @"xxx";
string input = @"abcdef abc<span abc>defabc abcdef</span> abc defabc";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}