# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,142|\D+/\n/g;t' <<< "[1142,143,2142,142]"