$re = '/,142|\D+/';
$str = '[1142,143,2142,142]';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;