package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`,142|\D+`)
var str = `[1142,143,2142,142]`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}