const regex = new RegExp(',142|\\D+', 'g')
const str = `[1142,143,2142,142]`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);