import Foundation
let pattern = #",142|\D+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[1142,143,2142,142]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)