#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",142|\D+"
Local $sString = "[1142,143,2142,142]"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)