using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",142|\D+";
string substitution = @"\n";
string input = @"[1142,143,2142,142]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}