use strict;
my $str = '[1142,143,2142,142]';
my $regex = qr/,142|\D+/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";