# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[A-Z])\s+(?=[A-Z])//g;t' <<< "I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000"