const regex = /(?<=[A-Z])\s+(?=[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Z])\\s+(?=[A-Z])', 'g')
const str = `I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);