use strict;
my $str = 'I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000';
my $regex = qr/(?<=[A-Z])\s+(?=[A-Z])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";