import re
regex = re.compile(r"(?<=[A-Z])\s+(?=[A-Z])")
test_str = "I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)