using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[A-Z])\s+(?=[A-Z])";
string substitution = @"";
string input = @"I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}