#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(END).*?(START)"
Local $sString = "STARTsadasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdas" & @CRLF & _
"das" & @CRLF & _
"dasdasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"sadasdENDasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"sadadSTARTsdasfgsdhtrwe" & @CRLF & _
"asdasdasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"sadadsdENDsadasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"START" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"AsdgrrgerENDetrtwtw" & @CRLF & _
"asdasdSTARTsadasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdas" & @CRLF & _
"das" & @CRLF & _
"dasdasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"sadasdENDasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"sadadSTARTsdasfgsdhtrwe" & @CRLF & _
"asdasdasdasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"sadadsdENDsadasd" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"START" & @CRLF & _
"asdasd" & @CRLF & _
"asdasdasf" & @CRLF & _
"asdfsdfsdf" & @CRLF & _
"sdfsd" & @CRLF & _
"fsdf" & @CRLF & _
"sdfasdsad" & @CRLF & _
"sd" & @CRLF & _
"fsd" & @CRLF & _
"fsdfsdfsdf" & @CRLF & _
"AsdgrrgerEND"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")