import re
regex = re.compile(r"(END).*?(START)", flags=re.DOTALL)
test_str = ("STARTsadasd\n"
"asdasd\n"
"asdasd\n"
"asdas\n"
"das\n"
"dasdasdasd\n"
"asdasd\n"
"sadasdENDasdasd\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"sadadSTARTsdasfgsdhtrwe\n"
"asdasdasdasd\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"sadadsdENDsadasd\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"START\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"AsdgrrgerENDetrtwtw\n"
"asdasdSTARTsadasd\n"
"asdasd\n"
"asdasd\n"
"asdas\n"
"das\n"
"dasdasdasd\n"
"asdasd\n"
"sadasdENDasdasd\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"sadadSTARTsdasfgsdhtrwe\n"
"asdasdasdasd\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"sadadsdENDsadasd\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"START\n"
"asdasd\n"
"asdasdasf\n"
"asdfsdfsdf\n"
"sdfsd\n"
"fsdf\n"
"sdfasdsad\n"
"sd\n"
"fsd\n"
"fsdfsdfsdf\n"
"AsdgrrgerEND")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")