import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(END).*?(START)";
final String string = "STARTsadasd\n"
+ "asdasd\n"
+ "asdasd\n"
+ "asdas\n"
+ "das\n"
+ "dasdasdasd\n"
+ "asdasd\n"
+ "sadasdENDasdasd\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "sadadSTARTsdasfgsdhtrwe\n"
+ "asdasdasdasd\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "sadadsdENDsadasd\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "START\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "AsdgrrgerENDetrtwtw\n"
+ "asdasdSTARTsadasd\n"
+ "asdasd\n"
+ "asdasd\n"
+ "asdas\n"
+ "das\n"
+ "dasdasdasd\n"
+ "asdasd\n"
+ "sadasdENDasdasd\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "sadadSTARTsdasfgsdhtrwe\n"
+ "asdasdasdasd\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "sadadsdENDsadasd\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "START\n"
+ "asdasd\n"
+ "asdasdasf\n"
+ "asdfsdfsdf\n"
+ "sdfsd\n"
+ "fsdf\n"
+ "sdfasdsad\n"
+ "sd\n"
+ "fsd\n"
+ "fsdfsdfsdf\n"
+ "AsdgrrgerEND";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}