const regex = /(END).*?(START)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(END).*?(START)', 'sg')
const str = `STARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerENDetrtwtw
asdasdSTARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerEND`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}