// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(END).*?(START)").unwrap();
let string = "STARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerENDetrtwtw
asdasdSTARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerEND";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}