#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(Mr\. |Miss\. |Master. |Mrs)"
Local $sString = "Cumings, Mrs. John Bradley (Florence Briggs Thayer)" & @CRLF & _
"Braund, Mr. Owen" & @CRLF & _
"Heikkinen, Miss. Laina" & @CRLF & _
"Futrelle, Mrs. Jacques Heath (Lily May Peel)" & @CRLF & _
"Palsson, Master. Gosta Leonard" & @CRLF & _
"Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)" & @CRLF & _
"Uruchurtu, Don. Manuel E"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")