// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Mr\. |Miss\. |Master. |Mrs)").unwrap();
let string = "Cumings, Mrs. John Bradley (Florence Briggs Thayer)
Braund, Mr. Owen
Heikkinen, Miss. Laina
Futrelle, Mrs. Jacques Heath (Lily May Peel)
Palsson, Master. Gosta Leonard
Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)
Uruchurtu, Don. Manuel E";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}