$re = '/(Mr\. |Miss\. |Master. |Mrs)/';
$str = 'Cumings, Mrs. John Bradley (Florence Briggs Thayer)
Braund, Mr. Owen
Heikkinen, Miss. Laina
Futrelle, Mrs. Jacques Heath (Lily May Peel)
Palsson, Master. Gosta Leonard
Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)
Uruchurtu, Don. Manuel E';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);