import re
regex = re.compile(r"(Mr\. |Miss\. |Master. |Mrs)")
test_str = ("Cumings, Mrs. John Bradley (Florence Briggs Thayer)\n"
"Braund, Mr. Owen\n"
"Heikkinen, Miss. Laina\n"
"Futrelle, Mrs. Jacques Heath (Lily May Peel)\n"
"Palsson, Master. Gosta Leonard\n"
"Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)\n"
"Uruchurtu, Don. Manuel E")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")