use strict;
my $str = 'Cumings, Mrs. John Bradley (Florence Briggs Thayer)
Braund, Mr. Owen
Heikkinen, Miss. Laina
Futrelle, Mrs. Jacques Heath (Lily May Peel)
Palsson, Master. Gosta Leonard
Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)
Uruchurtu, Don. Manuel E';
my $regex = qr/(Mr\. |Miss\. |Master. |Mrs)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}