import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Mr\\. |Miss\\. |Master. |Mrs)";
final String string = "Cumings, Mrs. John Bradley (Florence Briggs Thayer)\n"
+ "Braund, Mr. Owen\n"
+ "Heikkinen, Miss. Laina\n"
+ "Futrelle, Mrs. Jacques Heath (Lily May Peel)\n"
+ "Palsson, Master. Gosta Leonard\n"
+ "Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)\n"
+ "Uruchurtu, Don. Manuel E";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}