#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])"
Local $sString = "" & @CRLF & _
"//only accept az AZ and _ (underscore)" & @CRLF & _
"" & @CRLF & _
"#teste_teste //underscore accepted" & @CRLF & _
"#teste-teste //Hyphen not accepted" & @CRLF & _
"#leof_gfg.sdfsd //dot not accepted" & @CRLF & _
"#f34234@45#6fgh6 // @ not accepted" & @CRLF & _
"#leo#leo2#asd //followed hastag without space " & @CRLF & _
"#6663 // only number accepted" & @CRLF & _
"_#asd_ // hashtag can't start or finish with underscore" & @CRLF & _
"-#sdfsdf- // hashtag can't start or finish with hyphen" & @CRLF & _
".#sdfsdf. // hashtag can't start or finish with dot" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#leo_leo__leo__leo____leo //TO FIX: decline followed underline" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")