using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])";
string input = @"
//only accept az AZ and _ (underscore)
#teste_teste //underscore accepted
#teste-teste //Hyphen not accepted
#leof_gfg.sdfsd //dot not accepted
#f34234@45#6fgh6 // @ not accepted
#leo#leo2#asd //followed hastag without space
#6663 // only number accepted
_#asd_ // hashtag can't start or finish with underscore
-#sdfsdf- // hashtag can't start or finish with hyphen
.#sdfsdf. // hashtag can't start or finish with dot
#leo_leo__leo__leo____leo //TO FIX: decline followed underline
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}