use strict;
my $str = '
//only accept az AZ and _ (underscore)
#teste_teste //underscore accepted
#teste-teste //Hyphen not accepted
#leof_gfg.sdfsd //dot not accepted
#f34234@45#6fgh6 // @ not accepted
#leo#leo2#asd //followed hastag without space
#6663 // only number accepted
_#asd_ // hashtag can\'t start or finish with underscore
-#sdfsdf- // hashtag can\'t start or finish with hyphen
.#sdfsdf. // hashtag can\'t start or finish with dot
#leo_leo__leo__leo____leo //TO FIX: decline followed underline
';
my $regex = qr/#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}