const regex = /#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(\\w*[0-9a-zA-Z]+\\w*[0-9a-zA-Z])', 'g')
const str = `
//only accept az AZ and _ (underscore)
#teste_teste //underscore accepted
#teste-teste //Hyphen not accepted
#leof_gfg.sdfsd //dot not accepted
#f34234@45#6fgh6 // @ not accepted
#leo#leo2#asd //followed hastag without space
#6663 // only number accepted
_#asd_ // hashtag can't start or finish with underscore
-#sdfsdf- // hashtag can't start or finish with hyphen
.#sdfsdf. // hashtag can't start or finish with dot
#leo_leo__leo__leo____leo //TO FIX: decline followed underline
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}