import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(\\w*[0-9a-zA-Z]+\\w*[0-9a-zA-Z])";
final String string = "\n"
+ "//only accept az AZ and _ (underscore)\n\n"
+ "#teste_teste //underscore accepted\n"
+ "#teste-teste //Hyphen not accepted\n"
+ "#leof_gfg.sdfsd //dot not accepted\n"
+ "#f34234@45#6fgh6 // @ not accepted\n"
+ "#leo#leo2#asd //followed hastag without space \n"
+ "#6663 // only number accepted\n"
+ "_#asd_ // hashtag can't start or finish with underscore\n"
+ "-#sdfsdf- // hashtag can't start or finish with hyphen\n"
+ ".#sdfsdf. // hashtag can't start or finish with dot\n\n\n"
+ "#leo_leo__leo__leo____leo //TO FIX: decline followed underline\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}