$re = '/#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])/';
$str = '
//only accept az AZ and _ (underscore)
#teste_teste //underscore accepted
#teste-teste //Hyphen not accepted
#leof_gfg.sdfsd //dot not accepted
#f34234@45#6fgh6 // @ not accepted
#leo#leo2#asd //followed hastag without space
#6663 // only number accepted
_#asd_ // hashtag can\'t start or finish with underscore
-#sdfsdf- // hashtag can\'t start or finish with hyphen
.#sdfsdf. // hashtag can\'t start or finish with dot
#leo_leo__leo__leo____leo //TO FIX: decline followed underline
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);