// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])").unwrap();
let string = "
//only accept az AZ and _ (underscore)
#teste_teste //underscore accepted
#teste-teste //Hyphen not accepted
#leof_gfg.sdfsd //dot not accepted
#f34234@45#6fgh6 // @ not accepted
#leo#leo2#asd //followed hastag without space
#6663 // only number accepted
_#asd_ // hashtag can't start or finish with underscore
-#sdfsdf- // hashtag can't start or finish with hyphen
.#sdfsdf. // hashtag can't start or finish with dot
#leo_leo__leo__leo____leo //TO FIX: decline followed underline
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}