using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=""((\s|[a-zA-Z_-]{1}[\w-_]+)+)""";
string input = @"
<tag class=""something else"">yeah {{node.node}} </tag>
<tag class=""class1 class2"">yeah {{node.node}} </tag>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}