$re = '/class="((\s|[a-zA-Z_-]{1}[\w-_]+)+)"/';
$str = '
<tag class="something else">yeah {{node.node}} </tag>
<tag class="class1 class2">yeah {{node.node}} </tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);