import Foundation
let pattern = #"class="((\s|[a-zA-Z_-]{1}[\w-_]+)+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<tag class="something else">yeah {{node.node}} </tag>
<tag class="class1 class2">yeah {{node.node}} </tag>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)