import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\"((\\s|[a-zA-Z_-]{1}[\\w-_]+)+)\"";
final String string = "\n\n"
+ "<tag class=\"something else\">yeah {{node.node}} </tag>\n\n"
+ "<tag class=\"class1 class2\">yeah {{node.node}} </tag>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}