// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"class="((\s|[a-zA-Z_-]{1}[\w-_]+)+)""#).unwrap();
let string = "
<tag class=\"something else\">yeah {{node.node}} </tag>
<tag class=\"class1 class2\">yeah {{node.node}} </tag>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}