package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`class="((\s|[a-zA-Z_-]{1}[\w-_]+)+)"`)
var str = `
<tag class="something else">yeah {{node.node}} </tag>
<tag class="class1 class2">yeah {{node.node}} </tag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}