import re
regex = re.compile(r"class=\"((\s|[a-zA-Z_-]{1}[\w-_]+)+)\"")
test_str = ("\n\n"
"<tag class=\"something else\">yeah {{node.node}} </tag>\n\n"
"<tag class=\"class1 class2\">yeah {{node.node}} </tag>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")